Page 1 of 1

Red underline in Clang

PostPosted: Thu Dec 19, 2019 5:53 am
by d7d1cd
Good afternoon. If in C ++ Builder 10.3.2, when the Clang compiler is turned on, you enter the correct code, the system underlines the names of certain components in red. When you hover over the mouse, an error message appears. However, compiling this code is error-free. Is this a bug or can I configure it somewhere?
In addition, when entering a code after entering a dot (.) or an arrow (->), the hint must wait a long time.
A search on the Internet for these problems did not yield a result.

P.S. If the "classic" compiler is enabled, there are no such flaws.
Image

Re: Red underline in Clang

PostPosted: Thu Dec 19, 2019 1:05 pm
by Ahmed Sayed
Hi
I have the same issue as well. The code completion in C++ Builder does take a lot of time to calculate the result and LSP server consumes a lot of memory just to populate the list of functions and attributes for a TForm.

It is weird that Borland 5 C++ Builder Code completion was faster than later versions. Compared to Qt Creator and Visual Studio, C++ builder still needs a lot of work and I hope they fix it in the next version because it is a really show stopper, I still use RAD Studio berlin 10.1 UPD 2 and the code completion on this version crashes the IDE once I use the Clang compiler.

Regards

Re: Red underline in Clang

PostPosted: Fri Dec 20, 2019 3:10 pm
by rlebeau
d7d1cd wrote:If in C ++ Builder 10.3.2, when the Clang compiler is turned on, you enter the correct code, the system underlines the names of certain components in red. When you hover over the mouse, an error message appears. However, compiling this code is error-free. Is this a bug or can I configure it somewhere?


Error Insight has always been buggy. Best to just ignore it, even disable it.

Re: Red underline in Clang

PostPosted: Sun Dec 22, 2019 11:05 pm
by d7d1cd
rlebeau wrote:Best to just ignore it, even disable it.

Do you mean to completely disable all the tips? How to do it?

Re: Red underline in Clang

PostPosted: Fri Dec 27, 2019 8:12 am
by d7d1cd
I did not just ask how to disable tooltips in the editor. Having removed all the checkmarks, I did not get the desired effect: the editor continues to underline in red...